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概 要

　現在シリコン (Si)に代表される半導体や，2種類以上の元素からなる化合物半導
体は電気回路やコンピュータなどのデバイスに使用されており，私たちの生活に
は欠かせないものとなっている．しかし，半導体材料中には各種の欠陥が見られ，
使用したときにリーク電流が起こり，故障の原因となることが知られている．特
に積層欠陥は線欠陥（転位）の拡張幅を決定する要因で，半導体材料の欠陥生成
の容易さを知る上で重要なパラメータである．
　積層欠陥エネルギーは，zincblende(閃亜鉛鉱)構造（以下ZB構造）とwurtzite(ウ
ルツ鉱)構造（以下W構造）とのエネルギー差と相関があることが知られている．
本研究では，参考文献 [1]より実験的に得られている転位の拡張幅と，この２種の
構造エネルギー差の計算結果との相関を検討することを目的とした．　構造エネル
ギーの計算手法として，まず原子モデル構築ソフト’MedeA’を用いて結晶モデルを
作成した．作成したモデルの構造エネルギーは，第一原理計算ソフト’VASP(Vienna

Ab-initio Simulation Package)’を用いて算出した．
　結果として，計算した構造エネルギー差からわかる最安定構造と規定の最安定
構造では，GaN,ZnO,BeOにおいて矛盾している．また実験値の積層欠陥エネル
ギーとの比較において，計算結果との相関性が確認できなかった．ここで考えられ
るのが，VASPの計算誤差である．VASPで用いられている平面波擬ポテンシャル
法では軽元素での誤差が大きいとされている．よって，第二周期であるBe,C,N,O

を含む半導体または化合物半導体に関する計算結果には誤差があると考えられる．
　また単一元素からなる半導体とは異なり，イオン性のある化合物半導体におい
ては電荷量の偏りについて考慮するべきである．しかし本研究での計算は平面波
基底を用いており，電荷量の偏りをみるには局在基底を用いる必要がある．よっ
て今回はその点について検討することができなかった．
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第1章 序論

　昨今，我々の生活に欠かせないものとなっている半導体と化合物半導体．現在
シリコン (Si)に代表される半導体や，2種類以上の元素からなる化合物半導体は電
気回路や電気回路やコンピュータなどのデバイスに使用されている．また中国の
経済発展によるデジタル家電や携帯電話機の需要の増加，次世代を担うスーパー
コンピュータやロボットへの使用など，ますますの普及が期待されている．しか
し，半導体材料中には各種の欠陥が見られ，使用したときにリーク電流がおこり，
故障の原因となることが知られている．そこで本研究では，半導体材料の欠陥生
成の容易さを知る上で重要なパラメータである積層欠陥に着眼した．積層欠陥は
線欠陥（転位）の拡張幅を決定する要因である．また積層欠陥の起こりやすさで
ある積層欠陥エネルギーは，ZB構造とW構造とのエネルギー差と相関があるこ
とが知られている．本研究では，参考文献 [1]より実験的に得られている転位線の
拡張幅と，この２種の構造エネルギー差の計算結果との相関を検討することを目
的とした．

1.1 半導体と化合物半導体
　半導体とは，電気をよく通す良導体や電気を通さない絶縁体に対して，それ
らの中間的な性質を示す物質である．このとき，結晶構造はダイアモンド構造（以
下D構造）となる．電気をどの程度通すかという電気伝導性を周囲の電場や温度
によって敏感に変化させる性質は，今日の電子機械にとって重要であり，電子工学
で使用される ICのような半導体素子はこの半導体の性質を利用している．また，
化合物半導体とは，２つ以上の原子がイオン結合により結合して出来る半導体で
ある．一般的に，イオン結合は陽イオンと陰イオンとの強い静電引力によって絶
縁体になる．しかし，陽イオンと陰イオンの組み合わせによっては，静電引力が
弱く，半導体となる．このとき，結晶構造は ZB構造やW構造となる．化合物半
導体となる元素の組み合わせは代表的なものに III族とV族元素，II族とVI族元
素があり，それぞれ III-V族半導体，II-VI族半導体と呼ばれている．
　表 1.1は takeuchi-suzukiによってまとめられた２０種類の半導体または化合物
半導体の部分転位の拡張幅から求められた積層欠陥エネルギー及び c/aの値であ
る．[1]しかし ZB構造とW構造のエネルギー差は実験的には求まらないため，評
価されていない．そこで本研究では，各構造のエネルギー差を算出し，その結果
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と積層欠陥エネルギー及び c/aの値との比較を検討する．なお実験値の c/aの値に
おいてGaP，GaAs，GaSb，InP，InAsの値が空白になっているが，それらは本
来W構造をとるものではないために c/aの値が求まらないからである．本研究で
はそれらも無理矢理にW構造のモデルを作り c/aの値を算出していく．

1.2 積層欠陥と積層欠陥エネルギー
　結晶格子を格子面が規則的に積み重なった構造であると見なしたとき，その
積み重なり方の配列が乱れている面が積層欠陥（stacking fault）である．典型的
な積層欠陥は面心立方格子や六方最密格子の最密面に生じる積層欠陥である．例
えば，ZB構造は原子が ABCABC…という原子配列であるのに対し，W構造は
ABABAB…という原子配列である．ZB構造の規則的な原子配列に何らかの力が
加わることにより，原子配列が乱れABCBCA…とW構造をとる，これが積層欠
陥である．積層欠陥部分がBCBまたはCBCとなっていることから，そこがW構
造をとっていることがわかる．（図 1.1参照）また，積層欠陥の起こりやすさのこと
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を積層欠陥エネルギーと呼ぶ．

　　ここで，ZB構造とW構造のエネルギー差と積層欠陥エネルギーの相関性
について説明する．図 1.2において，積層欠陥が起きた方のモデルには２つのW

構造が含まれており，残りの５つは全て ZB構造である．よって，２つのW（以
下２W）と 4つのZB（以下 4ZB）からなる積層欠陥を含んだ結晶のエネルギーか
ら 6つの ZB（以下 6ZB）の完全結晶のエネルギーとの差をとれば，積層欠陥自体
のエネルギーを算出することが出来る．そして，ZB構造を持つ原子を増やしてい
くと，現実的な系に近づくので積層欠陥エネルギーに収束していく．（図 1.2）
　ところで，ZB構造は上にも記したがABCABC…という原子配列をとり，３層
で１周期となっている．これは立方晶系（cubic）の対称性を持っていることから，
３Cと記号する．W構造は，ABABAB…という２層が１周期となっている原子配
列である．これが六方晶系（hexagonal）の対称性を持っていることから，２Hと
記号する．同様に，ABCBABCB…という４層が１周期の原子配列のものは４H，
ABCACBABC…という６層が１周期の原子配列のものは６H，ABCABACB…と
いう８層が１周期の原子配列のものは８Hと記号する．（図 1.3,1.4,1.5参照）この
ように，これらの結晶多系の表記方法は，積層方向の単位格子に含まれる単位層
の数と，結晶系の頭文字（C：立方晶，H：六方晶）を組み合わせて表わされてい
る．積層欠陥をもっている実際の系は，ZB構造の中に限りなく低い比率でW構
造がはいっているため，６H，８Hなどとの相関を検討する方がより現実に近い
結果が出るが，かなりの計算時間を要するため時間の都合上本研究では３ Cと２

4



Hを用いた計算を行った．
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第2章 化合物半導体の構造エネル
ギーの第一原理計算

2.1 MedeA

結晶構造の作成のために，MedeAというソフトウェアを使用した．MedeAは
データベースと第一原理計算の手法を１つのプラットフォームで統合した，材料
設計支援のための統合ソフトウェアである．グラフィックスインターフェースおよ
び計算プログラムは全てWindowsシステム上で稼働するので，構造の検索，構築，
編集，計算，解析までを１つのプラットフォーム上で行うことができる．[2]

2.2 格子定数の計算
　格子の長さを変化させて，各々の系におけるエネルギーを計算する．その結
果を格子の長さについてプロットし，エネルギーが極小値をとる時の格子の長さ
を平衡な格子定数とする．

2.3 平面波基底擬ポテンシャル法
　密度汎関数に基づく第一原理擬ポテンシャル法によるバンド計算VASP code

を用いて計算を行う．この手法では，３次元周期境界条件を満たす平面波の基底
関数を用いて，電子被占有の軌道を展開し，その波動関数をもとに１電子方程式
を解くことにより電子状態を求める．交換相関ポテンシャルは GGA(generalized

gradient approximation)を用いた．そして，擬ポテンシャルとしてPAW(projector

augmented wave)を用いた．

2.4 VASP(Vienna Ab-initio Simulation Package)

　 VASP[3]は平面波擬ポテンシャル法（ならびに PAW法）による第一原理バ
ンド計算プログラムである．平面波基底の重ね合わせで波動関数を表現し，密度
汎関数理論に基づいて電子状態の計算を行う．平面波を使用する利点として，そ
の系の原子にかかる力の計算を正確かつ高速に行える点があげられる．このこと
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から，VASPは構造最適化や第一原理分子動力学計算のツールとして幅広く用い
られている．また，擬ポテンシャル法により内殻電子をポテンシャルに置き換え
て取り扱うので，波動関数の表現に用いる平面波基底の数を大幅に減らし，計算
量を軽減する．内殻電子の取り扱いについては，擬ポテンシャル法の他に，全電
子計算PAW法を採用しており，擬ポテンシャル法と比べてさほど計算量を増やす
こと無く，精度を上げることができる．バルク構造，表面，界面など多岐にわた
る問題に適用できる汎用的なソフトウェアである．また，VASPの計算を実行す
るために必要なファイルがどのような入力を担うかを簡単に記しておく．詳しく
は付録を参照せよ．

2.4.1 INCAR

　計算を制御するための入力パラメータがおさめられているファイル．VASPの
中心となるファイルで，VASPをどのように何をさせるか決めるものである．この
ファイルを扱うときにはエラーや失敗の元となるので気をつけなければならない．

# SCF input for VASP

# Note that VASP uses the FIRST occurence of a keyword

SYSTEM = (Si)4 (P6_3mc) ~tae 0.1 600 19 19 11 (VASP)

PREC = Accurate

ENCUT = 600

IBRION = 2

NSW = 100

ISIF = 3

ALGO = Normal (blocked Davidson)

NELM = 60

NELMIN = 2

EDIFF = 1.0e-05

EDIFFG = -0.02

VOSKOWN = 1

NBLOCK = 1

ISPIN = 1

INIWAV = 1

ISTART = 0

ICHARG = 2

LWAVE = .FALSE.

LCHARG = .FALSE.

ADDGRID = .FALSE.
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ISMEAR = 1

SIGMA = 0.2

LREAL = .FALSE.

RWIGS = 1.11

PREC

計算の精度を上げたり，下げたりすることが出来る．精度を上げればその分計算時
間は長くなる．Low／ Medium／ High／ Normal／ Accurateなどがあり，Nor-

mal と Accurate は VASP4.5 以降の ver. でのみ使用できる．(default=Medium)

NBANDS

バンドの数を決定するパラメータである．一般的には，記述しなくても適当な値
をとってくれる．しかし，大きな系で計算する時に，この値でよくエラーが生じ
る．単純にこのエラーを解決するには数値を大きくするだけで解決できるのであ
るが，その反面計算時間が長くなる．よって，最適なバンドの数を指定する必要
がある．その解決法として，次のようにすればよい．エラーが出ていようと出て
いなくても，計算を行うと OUTCAR というファイルが出来ている．その中に計
算に必要だったバンドの数が記載されている．つまり，その値をヒントにバンド
数を決定すればよい

IBRION

イオンのリラクゼーションの仕方を決定する．0 で分子動力学 (MD:molecular dy-

namics),1で準ニュートン法 (quasi-Newton),2で共役勾配法 (conjugate-gradient),3

で最急降下法を用いて計算する．(default=-1(NSW=0or1),default=0(else))

NSW

イオンのステップ数を決定するパラメータである．構造緩和において大変重要な
項目となる．つまり，少なすぎると，計算精度が落ち，収束せずに計算を終える
場合がある．その反面大きくすると計算時間が長くなる．(default=0)

ISIF

応力テンソルをどのように計算するかを決めるパラメータである．force や応力
テンソル，イオンのリラックス，セルの形や体積の変化など考慮するかしないか
を決定できる．詳しく表 2.2 に示す．応力テンソルの計算は比較的時間がかかる．
(default=0(IBRION=0),default=2(else))

ISMEAR

波動関数をどのような手法で表示するのかを設定するパラメータである．0 でガ
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ウスモデル，-1 でフェルミモデル，1 以上は Methfessel-Paxton 法を用いる．金
属のリラクゼーションを考慮する場合は 1 か 2 を用いるが，この二つは比較的同
じような解を算出する．(default=1)

EDIFF

電子計算の際，どの程度の差で計算を終了するかを決めるパラメータである．イ
タレーションごとに前の結果とのエネルギー差を算出し，その値が EDIFF で指
定した値以下になれば，計算が終了する．よって，より細かなデータが必要な時
にこの値を小さくすればよい．(default=10－ 4 )

2.4.2 KPOINTS

　 k点メッシュは３次元空間で表される．また，区切りの数は整数なので普通
のプログラムは a,b,c軸にそって逆空間を分割するように要求してくる．このとき
メッシュ間隔が均等になるようにした方がよい．時々単に k点の総数を聞いてく
る場合があるが，おそらくプログラム内部で自動的にメッシュを区切っていると
思われる．立方晶で３０と k点を指定しても立方根の整数をとるから３ x３ x３＝
２７のメッシュで実際には区切られることになる．次のメッシュは４ x４ x４＝６
４だから，３０，４０，５０，６０と kを変化させて収束を調べても，すべて２
７で計算している可能性があるので，見た目は全く同じ値を返すことに注意しな
ければならない．六方晶である hcpではこれと異なる．また k点の値は，リラク
ゼーションさせる方向と関連性がある．これという一般的な値はなく，k点の変化
によって時間や精度が変化してくるので，出来る限りその系での計算の都度検証
していくことが望ましい．

2.4.3 OUTCAR

　計算終了後に作成されるファイルで，有用なデータが出力されている．例え
ば，計算したバンドの数が載っている．また，原子にかかるフォースの大きさや
かかった計算時間なども出力される．計算時間に関しては，”time”コマンドを使
うことにより得られるが，これはバックグラウンドでの処理が出来ない難点があ
る．（小さい系で行う場合は問題ない．）よって，大きな系での計算精度や計算時間
を考察するときには，大変有用である
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2.4.4 POTCAR

　各元素のポテンシャルを明記したファイルである．POSCARで構築した原子
配列に関してどの原子を用いるかを決定する．１つのモデルの中に２種類以上の
元素を用いる場合は POSCARで指定した原子配列と関連づけなければならない．
また，カットオフエネルギーの値もこの POTCAR fileの中に存在する．しかし，
INCAR fileで直接的にカットオフエネルギーの値を指定することもできる．

cut-off energy

　波動関数をいろいろな平面波の足し合わせで考えるとき，より複雑な形の波動
関数を表現するためにはなるべく短い波長（つまり大きいエネルギー）の平面波
を使うとよい．ということで，カットオフエネルギーは，どこまで短い波長の平
面波を使うかに関連するパラメータだと言える．カットオフエネルギーを上げる
と，使用する波動関数の数が 3/2乗に従って増えるので，計算時間が大きく増加
することに注意する．

NPW =
V

3π2

(
2meEcut

h̄2

)2

(2.1)

2.4.5 POSCAR

　計算モデルの格子定数 (primitive vectors)と原子座標 (lattice coordinates)が
収められている．

2.5 PAW（Projector Augmented Wave）法
　 [4] 本論では，VASPを使用するに至り，擬ポテンシャル法として PAW法を
用いた．擬ポテンシャル法には，フルポテンシャル（全電子法），PAWポテンシャ
ル，（ウルトラソフト型）擬ポテンシャルの３つに分類される．PAWポテンシャル
はBlochlが考案した全電子計算の方法で，フルポテンシャルの精度と擬ポテンシャ
ルの高速性の両者を兼ね備えた方法で，それぞれの特徴を表に示す．また，その
模式図を図に示す．ポテンシャルVは無限に深いものであると考える．そのポテ
ンシャルを計算する際，擬ポテンシャル法では，図の赤線のようなポテンシャル
を仮想して計算する．反対にフルポテンシャルとフルポテンシャルの中間のポテ
ンシャルを計算する．よって，計算精度を維持しつつ，時間も短縮できる．（表 2.1，
図 2.1参照）
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第3章 結果

3.1 c/aと積層欠陥エネルギーの比較
　本研究では，各物質の最安定構造を求める際，格子定数・格子位置共に緩和
させて求める方法 (以下，full-relax)と，自分で格子定数を変化させる方法 (以下，
手計算)の２種をとった．これらの計算結果が一致すればその計算が信頼できるも
のであると考えられる．結果，全ての物質においてほぼ一致した．手計算で求め
た最安定構造を示す energy surfaceを図 3.1,3.2,3.3,3.4,3.5に，その構造エネルギー
と full-relaxで求められた構造エネルギーの比較を表 3.1に，それらと積層欠陥エ
ネルギーγ’との相関を図 3.6に示した．図 3.1-3.5の tt軸は格子定数 a,ss軸は格子
定数 c,縦軸はエネルギーを示している．ここで，図 3.6より，積層欠陥エネルギー
と c/aは比例の関係にあることが見受けられる．
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3.2 構造エネルギー差と積層欠陥エネルギーの比較
　計算での k－mesh，求めた構造エネルギー差 (ΔE)の一覧を表にまとめたも
のを以下の表 3.2,3.3に示した．それぞれ，cut-offは 600[eV]，k-pointは 0.1[/Å]で
設定してある．なお，この精度は非常に高精度で，信頼できる計算結果である

　ここでの構造エネルギー差は，W構造から ZB構造の構造エネルギーを引い
たものである．この表において，GaN,ZnO,BeOに関しては ZB構造の方が安定し
ている結果となり，規定のものと矛盾している．
　さらに，構造エネルギー差と積層欠陥エネルギー (γ’)との関係を示すグラフを
図 3.7に示した．
　これをみると，上にも記したとおりだが，GaN,ZnO,BeOに異常がみられる．本
来ならばD構造，ZB構造が安定している物質は第２象限に，W構造が安定して
いる物質は第３象限上に分布されなければならないが，この３物質に関してはそ
れに反するため，明らかに計算に誤りがある．ここで考えられるのが，VASPで
の計算の限界である．第２章で述べたように，VASPは平面波擬ポテンシャル法
（ならびにPAW法）による第一原理バンド計算プログラムである．しかし，それ
には軽元素（１周期．２周期の元素）の計算誤差が大きくなってしまうという弱
点がある．軽元素の誤差をなくすためにはフルポテンシャル法での計算を採用し
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なければならないが，西谷研究室で使用している計算ソフトはVASPのみであり，
現段階では不可能である．
　ここでVASPで計算した物質のうち，軽元素を除いた物質の構造エネルギー差
と積層欠陥エネルギーの関係を図 3.8に示した．ここでの軽元素とは，BeO，C，
AlN，InN，GaN，ZnOである．
　

　また，より確かな計算結果を検討するため，今回は，Si，GaAs，ZnO，CdSeの
４つの物質の２H，４H，６H，３C（Siについては８Hも）の関係を調べた．(図
3.9,3.10,3.11,3.12参照)理想的な形をとるのが，Siである，この図を見ると，GaAs

は理想的な結果であるが，ZnO，CdSeの結果が理想的でないことがうかがえる．
　ここで考えられる問題点として以下があげられる，ZnO，CdSeはW構造が最
安定であるが，ZB構造が最安定である場合と同様の考え方で計算している．W構
造が最安定の場合はW構造の中に積層欠陥がある結晶エネルギーとW構造の完
全結晶のエネルギーとの差分を求めるべきであった．ただし ZnOに関しては，軽
元素であるためにVASPの計算誤差であると考える．今回は時間の都合上この問
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題を追及できなかったが，この点に関しては今後更に検討していく必要がある．
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第4章 総括

本研究で得られた結果を以下に示す．

• 各物質の最安定構造を求める際，格子定数・格子位置共に緩和させて求める
方法と，自分で格子定数を変化させる方法の２種をとり，その双方の結果が
ほぼ一致した．またそれらと実験値の積層欠陥エネルギーとの相関性は高い
と見られる．

• 各構造のエネルギー差を求め，実験値の積層欠陥エネルギーとの相関性を検
討したが，VASPでの軽元素の計算には誤差が生じるため，正しい結果が得
られなかった．

• より正確な計算結果を検討するため，Si，GaAs，ZnO，CdSeの2H，4H，6H，
(8H)，3Cのエネルギーの比較をした際，チャージの偏りが本研究の結果に
影響しているのではないかという推論に至った．しかしVASPは平面波基底
を採用しており，本来局在基底により求められるチャージをVASPで算出す
るのは困難であるため，時間の都合上今回はこの問題について検討すること
が出来なかった．しかしこれについては今後更に追求していく必要がある．
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付録

A. MedeAの使用法

A.1 手法
1. MedeAを用いてセルを作る．

2. 第一原理ソフトVASPを用いて最安定構造とそのエネルギーを求める．

このような手順により最安定構造の格子定数とエネルギーを計算する．

A.2 セルの作成

A.2.1 モデルウィンドウを開く

　 Fileでは新しいファイルを作成したり，既にあるファイルを読み込んだりする
ことが出来る．ここでは，新しいファイルを作成する．MedeAのメインメニュー
から「File > New」を選択する．そうすると，周期境界を示すボックスのみが表示
された「Untitled」の名前がついたウィンドウが表示される．

A.2.2 対称性の設定

1. 対称性の情報を入力する．

2. MedeAのメインメニューから「Edit > Edit structure...」を選択する．また
は，モデルウィンドウ上でマウスを右クリックし，「Edit symmetry...」を選
択する．

3. 「Structure Editor」が表示される．デフォルトの対称性はP1となっている．
「Space-group:」の右にあるボタンをクリックする．D構造の対称性はFd_3m，
ZB構造の対称性は F_43m，W構造の対称性は P6_3mなので，「Primitive」
のリストの中から選択して OK のボタンをクリックする．

A.2.3 格子定数の設定
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1. 続いて，格子定数を変更する．デフォルトでは新しい格子の定数はa=b=c=10Å

となっている．

2. MedeAのメインメニューから「Edit > Edit structure...」を選択し，「Structure

Editor」を開いたら，「Cell」タブを選択する．または，モデルウィンドウ上
では右クリックし，「Edit Cell...」を選択する．

3. 先に対称性を入力しているので，D構造，ZB構造の場合ならば a軸のみ，W

構造の場合ならば a,c軸の格子定数を変更する．

4. 画面上の周期境界を表す黒い線上にマウスカーソルを持っていくと，MedeA

ウィンドウの下部に格子定数が表示される．

A.2.4 原子の入力

1. MedeAのメニューから「Edit > Edit structure...」を選択し，「Structure Ed-

itor」を開いたら「Add Atom」タブを選択する．または，右クリックから
「Add Atom...」を選択し，「Structure Editor」を開く．

2. 例えばGaAsの場合，デフォルトではCが入っているので，そこにGa原子
を挿入する．Ga原子はキーボード入力でGaと変更するか，その右側にある
アイコンをクリックして周期律表を開き，Gaを選択する．また同様にAsも
入力する．

A.3 VASPの計算

A.3.1 計算設定

1. MedeAのメインメニューから「Tools > VASP.4.6」を選択する．しばらくす
るとメインメニューに VASP.4.6が追加されるので，「VASP.4.6 > RUN」を
選択する．

2. Calculationタブで，以下の設定を行う．

• Type of calculation を Single Point から Structure Optimization に変
更する．

• Structure Optimization Parameters の３つのチェックボックス全てを
チェックする．

• Title は 自分の名前や精度などを入力しておくとわかりやすい．

• 設定が終わったら Run ボタンをクリックする．
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A.3.2 計算実行

1. プライオリティの指定を行う．

2. プライオリティとは優先度のことであり，数を多くすればするほど優先度が
上がる．デフォルトは５となっている．

3. 設定が終わったら Run ボタンをクリックする．

A.3.3 計算結果

1. MedeAメインメニューの「Job Control > View and Job Control」を選択す
る．しばらくすると，ウェブブラウザが起動し，ジョブ制御画面が現れる．

2. 黒いバーの中あるいはハイパーリンクされている Jobs をクリックすると，
ジョブ一覧表が表示される．

3. ジョブの番号が割り当てられる．Statusの部分には現在のジョブの状態がわ
かる．

4. Statusが finishedになった番号をクリックする．

5. Available Output Files の一番上のファイル Job.outをクリックする．この
ファイルが計算のサマリになる．

6. Job.outファイルの中には計算条件，計算結果，（構造，エネルギー，力，圧
力，計算時間）に関する情報が収められている．構造最適化計算を行った場
合は計算前後の構造についての情報が入っている．構造最適化の結果，元の
格子からわずかに格子が収縮した状態で安定構造が求まっている．
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